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MC9S12HY-Family Demonstration Lab 
Training
by: Gordon Borland, 

Steven McLaughlin
Microcontroller Solutions Group. Auto R & D
1 Introduction
This publication serves to document the demonstration 
lab software examples. The examples describe how to 
configure and use the modules for users to get started 
with the MC9S12HY Family of MCUs. 

The examples included here illustrate a basic 
configuration of the modules to allow users to quickly 
start developing their own applications.

Complete code is available for all examples. This can be 
downloaded onto an MC9S12HY64 target such as the 
DEMO9S12HY64 demo board upon which this 
demonstration lab is based.

Each module of the MC9S12HY Family has its own 
standalone software and is discussed within the 
respective section of this document.
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Setup
2 Setup

2.1 Tools Setup
NOTE

Before starting any of the module examples in this document, it is important 
that you install CodeWarrior Development Studio and CodeWarrior for 
Microcontrollers as described in the DEMO9S12HY64 Quick Start Guide 
that accompanies the demonstration board. 

2.2 Board Setup
The following steps provide a basic configuration for each of the module examples in this document. Any 
deviation from this basic configuration or any specific requirements for a module will be outlined in the 
relevant module chapter.

1. The DEMO9S12HY64 board should be configured with the default jumper settings as shown in 
the DEMO9S12HY64 Quick Start Guide that accompanies the demonstration board. 

2. Connect an A/B USB cable to an open USB port on the host PC and the USB connector on the 
DEMO9S12HY64 demonstration board. Follow the on-screen instructions to install the necessary 
USB drivers if required.

3. Move the ON/OFF switch (SW5) to the ON position. 
4. The green "+5V" LED above the ON/OFF switch should illuminate.

3 Demonstration Lab Examples

3.1 CPMU Clocks
This lab example shows how to produce PLL based bus clocks using different clock modes of the CPMU 
module. The example software initializes the PLL to run in default 8 MHz PEI mode, 12.5 MHz PEI mode, 
32 MHz PEE mode, and 4 MHz PBE mode. The changes in bus clock can be observed via the pulse rate 
of LED1 and the frequency can be measured by monitoring the ECLK signal (Bus clock) on an 
oscilloscope.

3.1.1 Setup

The following steps should be completed before running the lab example:
1. Start CodeWarriorTM by selecting it in the Microsoft Windows Start menu.
2. From the CodeWarrior main menu, select File > Open and select S12HY CPMU Demo.mcp file.
3. Click on the Open button. The project window will open.
4. The C code of this demonstration is contained within the main.c file. Double-click on the file to 

open it.
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Demonstration Lab Examples
5. From the main menu, select Project > Debug. This will compile the source code, generate an 
executable file, and download it to the demo board.

6. A new debugger environment will open. After the download to the demo board is completed, close 
the debugger environment.

7. The PLL configuration is sent to the serial communications port on the DEMO9S12HY64 board 
(baud rate = 9600, data bits = 8, parity = N, stop bits = 1, Flow control = Hardware). Open a 
terminal window on the PC with this configuration.

8. The bus clock speed is represented on pin 59 PH2/ECLK. The ECLK signal is equivalent to the 
MCU bus speed and can be monitored by attaching an oscilloscope probe to pin 23 of the DS1 
header.

3.1.2 Instructions

Follow these instructions to run the lab example:
1. Hit RESET. The MCU is now running in it's default PEI mode with a bus clock frequency of 

8 MHz. 
2. Monitor the ECLK signal on the oscilloscope. ECLK will match the bus clock frequency. Observe 

the LED pulse rate. Examine the PLL configuration on the terminal window.
3. Hit RESET whilst pressing down SW1. The MCU is now running in PEI mode with a bus clock 

frequency of 12.5 MHz.
4. Monitor the ECLK signal on the oscilloscope. ECLK will match the bus clock frequency. Observe 

the LED pulse rate. Examine the PLL configuration on the terminal window.
5. Hit RESET whilst pressing down SW2. The MCU is now running in PEE mode with a bus clock 

frequency of 32 MHz.
6. Monitor the ECLK signal on the oscilloscope. ECLK will match the bus clock frequency. Observe 

the LED pulse rate. Examine the PLL configuration on the terminal window.
7. Hit RESET whilst pressing down SW3. The MCU is now running in PBE mode with a bus clock 

frequency of 4 MHz.
8. Monitor the ECLK signal on the oscilloscope. ECLK will match the bus clock frequency. Observe 

the LED pulse rate. Examine the PLL configuration on the terminal window.

3.1.3 Summary

The CPMU PLL has three modes, PLL Engaged Internal Mode (PEI), PLL Engaged External Mode (PEE), 
and PLL Bypassed External Mode (PBE). 

From reset, the bus clock is derived from the CPMU PLL using the 1 MHz internally generated reference 
clock as it's source (PEI mode). This is the default clock mode from reset and will produce a bus clock of 
8 MHz.

For further information on the CPMU module please refer to the following documentation which is 
available at www.freescale.com.
MC9S12HY-Family Demonstration Lab Training, Rev. 0
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Demonstration Lab Examples
• Application note titled Comparison of the S12XS CRG Module with S12P CPMU Module 
(document AN3622)

• MC9S12HY64 Reference Manual (document MC9S12HY64RM)

3.2 Flash Programming Example

3.2.1 Flash Overview

The flash technology module (FTM- a 1.5T split gate transistor flash technology) contains program flash 
(P-flash), and data flash (D-flash). P-flash is intended primarily for non-volatile code storage. D-flash is 
used as basic flash memory for non-volatile data storage or non-volatile storage to support emulated 
EEPROM or a combination of both. The user interfaces with this module via the following steps. 

1. Set the flash clock divider (FCLKDIV).
2. Check the status of the Flash status register (FSTAT).
3. Make sure the command complete interrupt flag is set (CCIF=1).
4. Launch the appropriate flash commands (program, erase, verify and so on) via FCCOBIX and 

FCCOB registers.
5. Check flash status register and that CCIF=1.

A flow chart of these steps is shown below:
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Demonstration Lab Examples
3.2.2 Code Example Explanation and Walkthrough

The user will note that this program is compiled and run from RAM, because sections of flash will be 
erased in this example. The security information (0xFF0F) in the flash configuration field is not erased. 

NOTE
If the security information is accidently erased, the part will be secured and 
cannot be re-programmed until it is unsecured.

The file of interest is main.c. The purpose of this demonstration is to show:
• Launching a flash command.

Write to FCCOB register to load

Write: FSTAT register (to launch 

Write: FSTAT registeryes

no

Access Error and

noBit Polling for
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yes
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no
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Demonstration Lab Examples
• Demonstrate programming and erasing of flash.

This example has been written with a series of user software breakpoints so that the only thing that has to 
be done is to hit the Run  button. 

On start-up, the debugger should begin the program in ‘main’.

3.2.3 Breakpoint 1 — Launch Flash Command — Filling P-Flash

The importance at this breakpoint is the LaunchFlashCommand function. This function is responsible for 
exercising the flash block depending upon the flash command given. The flash commands are briefly 
described in the flash.h header file and within the S12HY reference manual, section 15.4, “Flash 
Command Description.” Stepping through will take the user to the function below.

Figure 1. Launch Flash command function

3.2.4 Breakpoint 2 - Launched Program Commands - Known Data

On entry of the second breakpoint, the memory maps have been set up to show the P-flash being erased 
(0xFFFF state), then programmed with known parameters (0xAAAA). All P-flash pages have been filled 
with 0xAAAA; 0x1400, 0x4000, 0xC000, and the PPAGE 0C-0F – 0x8000- 0xBFFF (local entry). 
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Figure 2. The memory maps showing real time erasing and programming

The user will note that 0x8000, the P-flash window will show different content depending on the PPAGE. 
When the programming has occurred, check PPAGE C-F by entering the character in the PPAGE register.

By altering the PPAGE, the user can see the 64k windows of programmed information at 0x8000.

3.2.5 Breakpoint 3 - Launched Program Commands - Address Data

Same as before, except the data being written to the P-flash is different; the data written is the actual 
addresses of the P-flash. 

D-flash P-flash P-flash P-flash P-flash
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3.2.6 Breakpoint 4 - D-flash - Launched Program Commands

The same functions are used but will now perform activity on the D-flash. The only differences to the flash 
command function is the memory address issued and flash commands — in other words, D-flash instead 
of P-flash.

The end of the demonstration is indicated by the LEDs on the EVB being toggled. This example does not 
re-program the device to default, this will happen on the next re-load of a program by allowing NVM 
erasing.

3.2.7 Summary

The demonstration software has shown how to initialize the flash command to perform programming, 
erasing, and erase verify on both the P-flash and D-flash. It is vital that the flow diagram is followed for 
correct operation. Deviation from this could cause errors when working with the P/D-flash. Although this 
demonstration did not include it, it is good practice to verify that the correct data has been programmed to 
the flash. 

3.3 Emulated EEPROM Driver

3.3.1 Emulated EEPROM Overview

Electrically Erasable Programmable Read-Only Memory (EEPROM), which can be byte or word 
programmed and erased, is often used in automotive electronic control units. This flexibility for program 
and erase operations makes it suitable for data storage of application variables that must be maintained 
when power is removed and needs to be updated individually during run-time. For the devices without 
EEPROM memory, the page-erasable flash memory can be used to emulate for EEPROM through 
EEPROM emulation software. 

The EEPROM emulation driver for S12HY implements the fixed-length data record scheme emulation on 
split gate flash. The EEPROM functionality to be emulated include organizing data records, initializing 
and de-initializing EEPROM, reporting EEPROM status, reading and writing data records. 

Four or more sectors shall be involved in emulation with a round robin scheduling scheme.

3.3.2 Code Example Explanation and Walkthrough

The file of interest is NormalDemo.c where the 'main' function resides. The purpose of this demonstration 
is to show how:

• The D-flash is initialized for EEE.
• The active and alternative sectors are assigned.
• The active sector is filled and swapped (and erased) with an alternative sector.

In an application only, the last point above is of relevance — the D-flash would be continually read and 
written to and sectors would be copied, swapped, and erased. This example has been written with a series 
of user software breakpoints so that the only thing that has to be done is to hit the Run  button. 
MC9S12HY-Family Demonstration Lab Training, Rev. 0
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On start-up, the debugger should begin the program in 'main' 

3.3.3 Breakpoint 1 — Erase the D-flash

On selecting the run button, the first software breakpoint will be hit. Breakpoint 1 stops at the function 
which is responsible for initializing the D-flash. This function erases and assigns the physical D-flash 
which shall be used for EEE. The user will notice that the selected D-flash (0x400, 0x500, 0x600, 0x700) 
will be in the erased state.

3.3.4 Breakpoint 2 — Initialize the Active and Alternative Sectors

The D-flash has now been erased and will have to be arranged as active and alternative sectors. This 
software driver requires that at least two alternative sectors are available. This is to deal with any brownout 
or dead sector situations. The 'FSL_InitEeprom' function initializes the two sectors at location 0x4400 and 
0x4500 to 'active' and the remaining sectors 0x4600, 0x4700, and 0x4800 to 'alternative'. On completion, 
the active sectors are defined by 0xFACF0000 and alternative are defined by 0xFFFF0000. 
MC9S12HY-Family Demonstration Lab Training, Rev. 0
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3.3.5 Breakpoint 3 — Write First Data and ID Record

The data to be written is defined within a header file — 0x10. When executed, this function will write the 
data 0x10 and will assign this with a record ID of 0x01. The ID size is 2 bytes and the data size has been 
configured to 6 bytes. The specific EEE user guide explains how to set the data size.

Active Sectors Alternative Sectors

Data Record
ID Record
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3.3.6 Breakpoint 4 — Completely Write the Active Sectors

This writes data records such that the active block is completely filled. The next write after the loop will 
cause a swap. The active sectors at 0x400 and 0x500 have been filled since the code executes a for loop 
until it reaches the end of the second active sector.

3.3.7 Breakpoint 5 — Sector Swap

Now that the active sectors have been completely filled, the next record write will only occur after a new 
active sector has been created. This is a two-stage process, firstly all the records from the first active sector 
are copied to the first available alternative sector — in this case, data and ID records from 0x400-0x499 
are copied to 0x600. Secondly, the sector at 0x400 is erased and becomes a new alternative sector. Notice 
on the new alternative sector, it begins with 0xFFFF0001. 

Active Sector
Completely filled (red)

Beginning of first 
alternative sector
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The process described whereby the sectors are being filled, copied, and erased will continue through an 
application, such as an odometer for example. When power to the application is lost, the data is stored in 
the D-flash and is easily read.

3.3.8 Breakpoint 6 — Reading EEE and Erase 

There are read functions after breakpoint 6 that are responsible for reading the EEE. This will read the 
record with a specified data and address. 

This demonstration program will complete by erasing the D-flash sectors and will end in the while loop.

Old active

sector now

becomes

alternative
Records
copied
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3.3.9 Summary

The demonstration software has shown how to initialize the D-flash for EEE operation by producing active 
and alternative sectors via the 'FSL_InitEeprom' function. The functions for writing, 'FSL_WriteEeprom' 
and reading, 'FSL_ReadEeprom' are required to write/read the appropriate data and accompanying ID 
records and hence emulate EEPROM. In an application it will be the two latter functions that will be relied 
upon. Moreover, the software is capable of dealing with brownout events as well as dead sectors. For 
developing applications with this code, it is advisable to read the EEE driver user's guide included 
Emulated EEPROM software pack, available from www.freescale.com.

3.4 MSCAN Module
This lab example uses the MSCAN module in loopback mode to transmit and receive a byte of data using 
standard length identifiers and four 16-bit filters. The status of the four switches, SW1 to SW4, is read and 
transmitted by the MSCAN module. When the MSCAN module receives its own transmission, the data in 
the message is read and displayed on the four LEDs.

When the MSCAN module is operated in loopback mode, no CAN signals are transmitted externally. Both 
the Tx and Rx pins are held high.

3.4.1 Setup

The following steps should be completed before running the lab example:
1. Start CodeWarriorTM by selecting it in the Microsoft Windows Start menu.
2. From the CodeWarrior main menu, select File > Open and select the S12HY MSCAN Demo.mcp 

file.
3. Click on the Open button. The project window will open.
4. The C code of this demonstration is contained within the main.c file. Double-click on the file to 

open it.
MC9S12HY-Family Demonstration Lab Training, Rev. 0
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Demonstration Lab Examples
5. From the main menu, select Project > Debug. This will compile the source code, generate an 
executable file, and download it to the demo board.

6. A new debugger environment will open. After the download to the demo board is completed, close 
the debugger environment.

3.4.2 Instructions

Follow these instructions to run the lab example:
1. Hit RESET. The MSCAN demo software will begin execution.
2. Press various combinations of the SW1, SW2, SW3, and SW4 switches. The LEDs should match 

their configuration. 

3.4.3 Summary

The MSCAN module is a serial data bus communication controller implementing the CAN 2.0A/B 
protocol as defined in the Bosch specification dated September 1991. It is not limited to automotive 
applications and is suited to wide variety of uses that require reliable communications. 

For further information on the MSCAN module, refer to the following documentation that is available at 
www.freescale.com.

• Application note titled Using MSCAN on the HCS12 Family (document AN3034)
• MC9S12HY64 Reference Manual (document MC9S12HY64RM)

3.5 PWM Module
This lab provides an example of how to setup and use the PWM module to create a 50% duty cycle output 
with different polarity and alignment settings. This behavior is best illustrated if all of the PWM signals 
can be displayed simultaneously on a four channel oscilloscope. 

3.5.1 Setup

The following steps should be completed before running the lab example:
1. Start CodeWarriorTM by selecting it in the Windows Start menu.
2. From the CodeWarrior main menu, select File > Open and select the S12HY PWM Demo.mcp 

file.
3. Click on the Open button. The project window will open.
4. The C code of this demonstration is contained within the main.c file. Double-click on the file to 

open it.
5. From the main menu, select Project > Debug. This will compile the source code, generate an 

executable file, and download it to the demo board.
6. A new debugger environment will open. After the download to the demo board is completed, close 

the debugger environment.
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3.5.2 Instructions

In order to give access to PWM signals on the J1 header, the software re-routes PWM[3:0] from PP[3:0] 
to PS[7:4]. 

Follow these instructions to run the lab example:
1. Hit RESET. The code should run and re-route the PWM channels. The PWM module should output 

50% duty cycle signals on ports PS7–PS4.
2. Try probing all four signals simultaneously if possible. This allows the difference in settings such 

as center alignment and polarity to be more apparent.

3.5.3 Summary

The PWM is a common module on many microcontrollers. It often finds use in applications that have a 
need to vary frequency or intensity, such as with lighting.

For further information on the PWM module, refer to the following documentation that is available at 
www.freescale.com.

• MC9S12HY64 Reference Manual (document MC9S12HY64RM)

3.6 S12HY Low Power Modes
In addition to the default Run mode, the MC9S12HY has three low power modes, Wait, Pseudo Stop, and 
Stop. 

Wait mode is similar to Run mode except that CPU execution is halted and it is possible to selectively 
disable some modules so that only necessary modules are clocked.

For lower power consumption, Pseudo Stop mode halts the bus clock, but the external oscillator continues 
to run.

Stop Mode disables the external oscillator for the lowest power consumption.

This lab example shows how to enter each mode and the differences between them. 

The table below summarizes the signals present in each mode.

The changes in the MCU operating mode can be observed via the LEDs and by monitoring the ECLK 
signal (Bus clock) and EXTAL signal (Crystal) on an oscilloscope.

Care should be taken to probe ECLK and EXTAL separately to avoid adding extra noise to the signals.

Mode Bus Clock External Oscillator

Run Y Y

Wait Y Y

Pseudo Stop N Y

Stop N N
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Freescale Semiconductor 15

www.freescale.com


Demonstration Lab Examples
3.6.1 Setup

The following steps should be completed before running the lab example:
1. Start CodeWarriorTM by selecting it in the Microsoft Windows Start menu.
2. From the CodeWarrior main menu, select File > Open and select the S12HY Low Power 

Modes.mcp file.
3. Click on the Open button. The project window will open.
4. The C code of this demonstration is contained within the main.c file. Double-click on the file to 

open it.
5. From the main menu, select Project > Debug. This will compile the source code, generate an 

executable file, and download it to the demo board.
6. A new debugger environment will open. After the download to the demo board is completed, close 

the debugger environment.
7. The bus clock speed is represented on pin 59 PH2/ECLK. The ECLK signal is equivalent to the 

MCU bus speed and can be monitored by attaching an oscilloscope probe to pin 23 of the DS1 
header.

8. The oscillator can be monitored by attaching a scope probe to the EXTAL side of the Y1 crystal.

3.6.2 Instructions

Follow these instructions to run the lab example:
1. Hit RESET. The MCU is now operating in Run mode. The LEDs will flash indefinitely indicating 

the MCU is in Run mode. 
2. Monitor the ECLK signal on the oscilloscope. ECLK represents the bus clock. A 32 MHz square 

wave should be observed. 
3. Monitor the EXTAL signal on the oscilloscope. EXTAL indicates that the crystal oscillator is 

running. An 8 MHz sine wave should be observed. 
4. Hit RESET whilst pressing down SW1. LED1 will flash twenty times indicating Run mode and 

then the MCU will enter into Wait mode. Pressing SW4 causes the MCU to exit Wait mode back 
into Run mode. LED1 will flash twenty times before the MCU returns into Wait mode again.

5. Monitor the ECLK signal on the oscilloscope. The 32 MHz square wave representing the bus clock 
will be present in both Run and Wait modes. 

6. Monitor the EXTAL signal on the oscilloscope. In both Run and Wait modes, an 8 MHz sine wave 
should be observed indicating that the external oscillator continues to operate in Wait mode.

7. Hit RESET whilst pressing down SW2. LED1 will flash twenty times indicating Run mode and 
then the MCU will enter into Pseudo Stop mode. Pressing SW4 causes the MCU to exit Pseudo 
Stop mode back into Run mode. LED1 will flash twenty times before the MCU returns into Pseudo 
Stop mode again.

8. Monitor the ECLK signal on the oscilloscope. The 32 MHz square wave representing the bus clock 
is only present in Run mode. In Pseudo Stop mode, the bus clock is stopped to save power. 
MC9S12HY-Family Demonstration Lab Training, Rev. 0
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9. Monitor the EXTAL signal on the oscilloscope. In both Run and Pseudo Stop modes, an 8 MHz 
sine wave should be observed indicating that the external oscillator continues to operate in Pseudo 
Stop mode.

10. Hit RESET whilst pressing down SW3. LED1 will flash twenty times indicating Run mode and 
then the MCU will enter into Stop mode. Pressing SW4 causes the MCU to exit Stop mode back 
into Run mode. LED1 will flash twenty times before the MCU enters returns into Stop mode again.

11. Monitor the ECLK signal on the oscilloscope. The 32 MHz square wave representing the bus clock 
is only present in Run mode. In Stop mode, the bus clock is stopped to save power. 

12. Monitor the EXTAL signal on the oscilloscope. The 8 MHz sine wave is only present in Run mode. 
In Stop mode, the external oscillator is stopped to save power.

3.6.3 Summary

The MC9S12HY Family can be configured in a variety of ways to achieve low power consumption. The 
three low power modes offer different solutions for user applications.  

For further information on low power modes, refer to the following documentation available at 
www.freescale.com.

• Application note titled Low Power Management Using HCS12 and SBC Devices (document 
AN2461)

• MC9S12HY64 Reference Manual (document MC9S12HY64RM)

3.7 MMC Program Flash Paging Window
The MC9S12HY64 has Flash memory of 64 KB. Whilst this amount of memory can be addressed by the 
16-bit MC9S12HY64 MCU, there is insufficient local address space to accommodate all of the Flash 
memory, the RAM memory, and the register space. Instead, a paging system which maps 16 KB blocks of 
memory into the local memory map from address 0x8000 to 0xBFFF is used.

This lab example shows how to use the paging capability of the MMC module to access global memory 
addresses within the local memory map. 

3.7.1 Setup

The following steps should be completed before running the lab example:
1. Start CodeWarriorTM by selecting it in the Microsoft Windows Start menu.
2. From the CodeWarrior main menu, select File > Open and select the S12HY MMC Demo.mcp 

file.
3. Click on the Open button. The project window will open.
4. The C code of this demonstration is contained within the main.c file. Double-click on the file to 

open it.
5. From the main menu, select Project > Debug. This will compile the source code, generate an 

executable file, and download it to the demo board.
6. A new debugger environment will open. Do not close the debugger environment.
MC9S12HY-Family Demonstration Lab Training, Rev. 0
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3.7.2 Instructions

Follow these instructions to run the lab example:
1. The Memory window in the debugger environment is configured to show the first few locations 

of the P-flash window at address 0x8000.

2. The Register window in the debugger environment shows the setting of the Program Page Index 
Register (PPAGE).

3. Start the software by clicking on the Run  button.
4. When the software hits the first breakpoint, examine the contents of the Memory and Register 

windows. The PPAGE register is set to 0C and the P-flash window shown in the Memory window 
displays the contents of PPAGE 0C.
MC9S12HY-Family Demonstration Lab Training, Rev. 0
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5. Hit the Run button and observe the Memory and Register windows at the next breakpoint.
6. Now the PPAGE register is set to 0D and the P-flash window shown in the Memory window 

displays the contents of PPAGE 0D.

7. Hit the Run button and observe the Memory" and "Register" windows at the next breakpoint.
8. Now the PPAGE register is set to 0E and the P-Flash Window shown in the "Memory" window 

displays the contents of PPAGE 0E.

9. Hit the Run button and observe the Memory and Register windows at the next breakpoint.
10. Now the PPAGE register is set to 0F and the P-flash window shown in the Memory window 

displays the contents of PPAGE 0F.
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11. Hit the Run button and the software will loop back to return the PPAGE register to 0C. The 
contents of PPAGE 0C can be seen in the Memory window.

3.7.3 Summary

The MMC module can be used to expand the accessible amount of memory of the MC9S12HY64 MCU 
by paging the expanded global memory into a window in local memory.

For further information on the MMC module, refer to the following documentation available at 
www.freescale.com.

• MC9S12HY64 Reference Manual (document MC9S12HY64RM)

3.8 ADC Module
This lab example shows how to use the ADC module to perform single conversions, continuous 
conversions, and automatic compare. The ADC conversion results are output on a terminal window via the 
RS-232 port. 

3.8.1 Setup

The following steps should be completed before running the lab example:
1. Start CodeWarriorTM by selecting it in the Microsoft Windows Start menu.
2. From the CodeWarrior main menu, select File > Open and select the S12HY ADC Demo.mcp file.
3. Click on the Open button. The project window will open.
4. The C code of this demonstration is contained within the main.c file. Double-click on the file to 

open it.
5. From the main menu, select Project > Debug. This will compile the source code, generate an 

executable file, and download it to the demo board.
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6. A new debugger environment will open. After the download to the demo board is completed, close 
the debugger environment.

7. The ADC conversion result is sent to the RS-232 port (baud rate = 9600, data bits = 8, parity = N, 
stop bits = 1, Flow control = Hardware). Open a terminal window on the PC with this 
configuration.

3.8.2 Instructions

Follow these instructions to run the lab example:
1. Hit RESET. The ADC will perform a single 12-Bit conversion on PAD00. To perform another 

conversion press SW4.
2. Vary the conversion result by turning potentiometer RV1 on PAD00 and observe the changes in the 

terminal window.
3. Hit RESET whilst pressing down SW1. The ADC will perform continuous 8-bit conversions on 

PAD00. 
4. Vary the conversion result by turning potentiometer RV1 on PAD00 and observe the changes in the 

terminal window.
5. Hit RESET whilst pressing down SW2. The ADC will perform continuous 12-bit conversions on 

PAD00 and compare the result to see if it is higher than 0x07FF. Whilst the comparison is true, 
LED1 on the demo board will flash. 

6. Vary the conversion result by turning potentiometer P501 on PAD00 and observe the result in the 
terminal window. Notice how LED1 only flashes when the result is greater than 0x07FF.

3.8.3 Summary

The ADC module is highly autonomous with an array of flexible conversion sequences and resolution. It 
can be configured to select which analogue source to start conversion on, how many conversions to 
perform, and whether these should be on the same or multiple input channels. An automatic compare can 
be used to liken the conversion result against a programmable value for higher than or less than/equal to 
matching. Any conversion sequence can be repeated continuously without additional MCU overhead.

For further information on the ADC module, refer to the following documentation available at 
www.freescale.com.

• Application note titled An Overview of the HCS12 ATD Module (document AN2428)
• MC9S12HY64 Reference Manual (document MC9S12HY64RM)

3.9 Timer Module
This lab example shows how to use the Timer module to perform output compare and input capture. In 
case an oscilloscope is unavailable, the LEDs associated with Port R on the DEMO9S12HY64 board are 
used to indicate port toggles due to an output compare match, or a successful input capture. 
MC9S12HY-Family Demonstration Lab Training, Rev. 0

Freescale Semiconductor 21

www.freescale.com


Demonstration Lab Examples
3.9.1 Setup

The following steps should be completed before running the lab example:
1. Ensure that the LED4 and POT jumpers on JP14 have been removed. 
2. Connect the potentiometer output (pin 18 on JP14) to Port R3 (pin 7 on JP14). This will allow the 

potentiometer RV1 to provide stimulus to the input capture function on IOC1_7. 
3. Start CodeWarriorTM by selecting it in the Microsoft Windows Start menu.
4. From the CodeWarrior main menu, select File > Open and select the S12HY Timer Demo.mcp 

file.
5. Click on the Open button. The project window will open.
6. The C code of this demonstration is contained within the main.c file. Double-click on the file to 

open it.
7. From the main menu, select Project > Debug. This will compile the source code, generate an 

executable file, and download it to the demo board.
8. A new debugger environment will open. After the download to the demo board is completed, close 

the debugger environment.

3.9.2 Instructions

In order to drive LEDs directly from Timer output channels, the software re-routes the Timer 0 channels 
IOC0_7 and IOC0_6 from Port T7:6 to Port R1:0. In addition, to allow a connection to an input capture 
channel, the software also re-routes Timer 1 channel IOC1_7 from Port T3 to Port R3. The re-routing also 
gives the user access to the signals on the J1 header

Follow these instructions to run the lab example:
1. Hit RESET. The code should run and re-route the Timer channels.
2. Timer 0 will perform output compares on channels IOC0_7 (Port R1 re-routed from Port T7) and 

IOC0_6 (Port R0 re-routed from Port T6). When a compare match occurs on IOC0_7, Port R1 will 
toggle. When a match compare occurs on IOC0_6, Port R0 will toggle.

3. Timer 1 will perform input capture on both rising and falling edges on channel IOC1_7 (Port R3 
re-routed from Port T3).

4. Use an oscilloscope to view the toggling Timer 0 channels IOC0_7 and IOC0_6 on Port pins R1 
and R0 (J1 header pins 11 and 9). In case an oscilloscope is not available, the LEDs associated with 
Port R1 (LED2) and Port R0 (LED1) toggle in sync with the Timer channels.

5. Use the potentiometer RV1 to create rail to rail rising and falling edges on Timer 1 channel 
IOC1_7.

6. To ensure the input capture is detecting edge transitions, observe LED3 toggles with each rising or 
falling edge.
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3.9.3 Summary

The timer is a very useful module in that it provides a trigger for events to occur at a specific time, or 
captures when events have occurred. It is very important in the scheduling of repetitive actions and 
contains a variety of special functions, such as pulse accumulation.

For further information on the timer module, refer to the following documentation available at 
www.freescale.com.

• MC9S12HY64 Reference Manual (document MC9S12HY64RM)

3.10 SCI Communications
This lab example shows how to configure the SCI module to transmit and receive data using different baud 
rates. 

3.10.1 Setup

The following steps should be followed before running the lab example:
1. Ensure that both the BCOM_EN jumpers on JP11 have been removed.
2. Start CodeWarriorTM by selecting it in the Microsoft Windows Start menu.
3. From the CodeWarrior main menu, select File > Open and select the S12HY SCI Demo.mcp file.
4. Click on the Open button. The project window will open.

3.10.2 Instructions

Follow these instructions to run the lab example:
1. The C code of this demonstration is contained within the main.c file. Double-click on the file to 

open it.
2. Configure the variable "Baud_Rate" to 9600 and make sure all other options are disabled.

3. From the main menu, select Project > Debug. This will compile the source code, generate an 
executable file, and download it to the demo board.

4. A new debugger environment will open. 
5. The software uses the RS-232 port to interact with the user. Open a terminal window (baud rate = 

9600, data bits = 8, parity = N, stop bits = 1, Flow control = Hardware) to see the RS-232 port data.
6. Hit F5. The code will begin execution, configuring the SCI to the selected baud rate. It's status can 

be confirmed on the terminal window.
7. The SCI register configurations can be confirmed by selecting an option displayed on the terminal 

window. Select some options and observe the SCI register configurations.
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8. Repeat steps 2 to 9 for baud rates of 19200, 38400 and 57600. Alternatively, modify the definition 
of variable "Baud_Rate" for a user configured baud rate. 

3.10.3 Summary

The SCI module can be used to communicate with peripheral devices or other MCUs.

For further information on the SCI module please refer to the following documentation which is available 
at www.freescale.com.

• Application note titled Serial Communication Interface as UART on HCS12 MCUs (document 
AN2883)

• MC9S12HY64 Reference Manual (document MC9S12HY64RM)

3.11 SPI Communications
This lab example shows how to set up and use the SPI module in master mode to transmit an incrementing 
byte of data. 

As there is only one SPI module available on the DEMO9S12HY64 board, this example is limited to 
transmitting data only. When an SPI master transmits data to an SPI slave, data is usually received 
simultaneously, synchronized by a serial clock.

3.11.1 Setup

An oscilloscope and three scope probes are required for this demo. The following steps should be 
completed before running the lab example.

1. Start CodeWarriorTM by selecting it in the Microsoft Windows Start menu.
2. From the CodeWarrior main menu, select File > Open and select the S12HY SPI Demo.mcp file.
3. Click on the Open button. The project window will open. 
4. The C code of this demonstration is contained within the main.c file. Double-click on the file to 

open it.
5. From the main menu, select Project > Debug. This will compile the source code, generate an 

executable file, and download it to the demo board.
6. A new debugger environment will open. After the download to the demo board is completed, close 

the debugger environment.
7. Attach scope probes to signals PS4, PS6, and PS7 on header J1.
8. Configure the oscilloscope to trigger on the falling edge of PS7.

3.11.2 Instructions

Follow these instructions to run the lab example:
1. Hit RESET. The code will begin execution, configuring the SPI to transmit an incrementing byte 

of data at a baud rate of 15.625 kbits/s. 
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2. Monitor the SPI transmission on the oscilloscope to see the relationship between Slave Select 
(PS7), data transmitted on MOSI (PS4), and the Serial Clock (PS6) signals.

3.11.3 Summary

The SPI module can be used to allow duplex synchronous serial communication between peripheral 
devices and the MCU. 

For further information on the SPI module, refer to the following documentation available at 
www.freescale.com.

• MC9S12HY64 Reference Manual (document MC9S12HY64RM)

3.12 Motor Control Module
This demonstration code has been constructed to explain how to set up the motor control module and 
operate an external stepper motor. In order to operate this demo, the user will require connecting an 
external motor to PTU0-3.

3.12.1 Setup
1. Connect a stepper motor to Motor 0 pins, PTU0-3 -J3 on the demo board.
2. Start CodeWarriorTM by selecting it in the Microsoft Windows Start menu.
3. From the CodeWarrior main menu, select File > Open and select the S12HY_MC_DEMO.mcp 

file.
4. Click on the Open button. The project window will open. 
5. The C code of this demonstration is contained within the main.c file. Double-click on the file to 

open it.
6. From the main menu, select Project > Debug. This will compile the source code, generate an 

executable file, and download it to the demo board.

The motor control module is set up via the 'MC_init' function where the motor control registers are 
configured. The module can be set to operate in various modes; in this case it is operated in dual full 
H-bridge, which is ideal for controlling stepper motors. The physical set-up of the motor requires 4 
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connections, whereby each PWM channels has two connections. See S12HY reference manual, section 
17.4.1.1.1, “Dual Full H-Bridge Mode.”

Figure 3. Dual full H-bridge configuration

3.12.2 Instructions

This is a self-contained example in which the user requires no intervention. On running the program, the 
motor will initialize by returning to zero (RTZ) position. The motor is simply controlled by adjusted the 
potentiometer RV1 on the board. 

3.12.3 Summary

This demonstration has shown that it is possible to control the movement of a stepper motor and this basic 
example can be applied to many types of applications. 

3.13 LCD Module
The demonstration code incorporates an example of an odometer display and trip meters, which 
increments in real time. There are also other common items displayed and updated on the LCD to emulate 
a dashboard unit display. This document serves to describe the software and explain the operation of the 
LCD module.

3.13.1 Setup
1. Start CodeWarriorTM by selecting it in the Microsoft Windows Start menu.
2. From the CodeWarrior main menu, select File > Open and select the S12HY_LCD_DEMO.mcp 

file.
3. Click on the Open button. The project window will open. 
4. The C code of this demonstration is contained within the main.c file. Double-click on the file to 

open it.
5. From the main menu, select Project > Debug. This will compile the source code, generate an 

executable file and download it to the demo board.

In order to begin using the LCD, the pins which operate the front-planes and backplanes must be 
configured. This is made easy for the user because when the LCD module is enabled, performed in the 
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LCD_Init function, the 44 pins will output an LCD driver waveform based on the DUTY and BIAS 
settings in LCDCR0.

Figure 4. LCD initialization functions

The frequency at which the LCD glass should be operated at will be given by the glass manufacturer and 
in the case of this demo it is 61 Hz. This is obtained by setting the frame frequency via the LCD clock 
prescaler bits. Table 16-8 of the S12HY/HA reference manual provides some information of LCD clock 
vs. frame frequency.

The LCD module has a dedicated 20 bytes of RAM at 0x208 which contains the data that is displayed on 
the 160 segment LCD. This LCD RAM interfaces with the internal address and data buses of the MCU. 
During any type of power cycle, the contents of the RAM can be indeterminate, therefore it is 
recommended to set the 20 bytes of RAM to a known state prior to exercising it. 

3.13.2 Instructions

This is a self-contained example, in which the user requires no intervention. On program start-up, the LCD 
displays 'S12HY' and will proceed into a never-ending for loop, which is responsible for the updating and 
animation of the LCD display. 

A port interrupt has also been used on analog ports that are connected to the switches. On pressing SW1 
on the hardware, this allows the user to switch the LCD numerical display between ODO, TRIPA, and 
TRIPB. 

3.13.3 Summary

This demonstration has shown that controlling the LCD is a matter of updating the dedicated RAM and 
manipulating the backplane and frontplane pins. This demonstration does not save the information during 
power down, so the user will find the odometer and trip information have been reset. A further exercise to 
this example would be to use the emulated EEPROM driver, available freely from Freescale, to enable 
recovery of this information, and by continuously reading and writing the data to the device's D-flash. 

4 Conclusion
The S12HY Family of MCUs offers the enhanced features of 16-bit performance at the value of 8-bit 
MCUs. The S12HY family bridges the gap between 8- and 16-bit MCUs and serves as an entry point into 
Freescale's 16-bit family offerings, giving customers the flexibility to enhance or cost reduce their 
applications. 
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The S12HY family is ideal for a wide range of central body control applications, such as low-end 
instrument clusters, window lifts, seat controllers, sunroofs, door modules, low-end Anti-lock Brake 
Systems (ABS), Electronic Power Steering (EPS), and watchdog control.

A zip file, AN4021SW.zip, containing the complete CodeWarrior projects for the lab examples 
accompanies this application note. The file can be downloaded from www.freescale.com. 

5 References
The following material is available at www.freescale.com.

Software Development Tools
• CodeWarrior for HCS12(X) Microcontrollers

Application Notes
• Application note titled Stepper Stall Detect Software for S12HY (document AN4024)
• Application note titled XGATE Library: TN/STN LCD Driver (document AN3219)
• Application note titled Comparison of the S12XS CRG Module with S12P CPMU Module 

(document AN3622)
• Application note titled Using MSCAN on the HCS12 Family (document AN3034)
• Application note titled PWM Generation Using HCS12 Timer Channels (document AN2612)
• Application note titled An Overview of the HCS12 ATD Module (document AN2428)
• Application note titled Serial Communication Interface as UART on HCS12 MCUs (document 

AN2883)
• Application note titled Low Power Management Using HCS12 and SBC Devices (document 

AN2461)

Reference Manual
• MC9S12HY64 Reference Manual (document MC9S12HY64RM)
• Automotive Cluster Demo Guide (document S12HY64ACDUG)

Useful Information
• Tips for driving LCDs 
• S12HY64 Video Demonstration
• Emulated EEPROM software driver
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